Jump to content

Steam deck


Hannspree
 Share

Recommended Posts

The updater currently doesn’t work under proton but the client does. You’ll have to make sure you sync your updates some other way until we can fix that but you can launch the client directly. If you’re using steam the parameters should be “trose.exe —init—server connect.roseonlinegame.com”

 

Note those should be double - but might not look like that in my message.

  • Like 1
Link to comment
Share on other sites

12 hours ago, lazypenguin said:

The updater currently doesn’t work under proton but the client does. You’ll have to make sure you sync your updates some other way until we can fix that but you can launch the client directly. If you’re using steam the parameters should be “trose.exe —init—server connect.roseonlinegame.com”

 

Note those should be double - but might not look like that in my message.

Thanks ill try that 🙂 take it I could copy the files from my laptop to the steam deck 

Link to comment
Share on other sites

14 hours ago, lazypenguin said:

The updater currently doesn’t work under proton but the client does. You’ll have to make sure you sync your updates some other way until we can fix that but you can launch the client directly. If you’re using steam the parameters should be “trose.exe —init—server connect.roseonlinegame.com”

 

Note those should be double - but might not look like that in my message.

No luck 😞 think I done it right 

20221220_092522.jpg

Link to comment
Share on other sites

3 hours ago, Hannspree said:

Yep and tried all the different ones 

Well, I know we had some trouble running rose even on Windows, due to the lack of this lil shit: Microsoft Edge WebView2 (   developer.microsoft.com/en-us/microsoft-edge/webview2/   );

I was getting the same behavior that i launch the game it opens and close the launcher in the blink of an eye. Maybe if you can get this complement to work, it could solve the question...
 

Link to comment
Share on other sites

Make sure your installation is up to date as mention, because the launcher wont work and if the game isnt patched correctly maybe it can prevent it from opening. After that it should work smoothly, here is my settings if it helps you(Im on pop_os its based on ubuntu)

Screenshot from 2022-12-20 16-14-29.png

Screenshot from 2022-12-20 16-14-40.png

  • Thanks 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...